Back to overview
Degraded

Nitro under attack

Apr 12, 2026 at 12:21pm UTC
Affected services
Nitro
MythicHearts SMP

Resolved
Apr 12, 2026 at 11:20pm UTC

The DDOS attack has ended, and service should continue as usual. This will bring any servers hosted on Nitro online.

Created
Apr 12, 2026 at 12:21pm UTC

The Nitro server in Israel is currently under a DDOS attack from a rival hosting company from the owners of it and may be down or have limited service for several hours or days.